Roundcube 邮件系统发现重要漏洞,需要尽快升级

 中国邮箱网  0条评论  1308次浏览  2020年08月18日 星期二 14:58

分享到: 更多
中国邮箱网讯 8月18日消息 Roundcube是一款被广泛使用的开源的Web电子邮件程序,在全球范围内有很多组织和公司都在使用。Roundcube Webmail在Linux中最常用,它提供了基于Web浏览器的可换肤IMAP客户端,并提供多种语言。功能包括MIME支持,通讯簿,文件夹和邮件搜索功能。Roundcube支持各种邮件协议,如IMAPS、POP3S 或者 submission,可以管理多个邮箱账号.

不过,Roundcube Webmail 1.4.8之前版本中存在跨站脚本漏洞。

漏洞详情

跨站脚本(XSS)漏洞 (CVE-2020-16145)

跨站脚本(XSS)攻击通常指的是通过利用网页开发时留下的漏洞,通过巧妙的方法注入恶意指令代码到网页,使用户加载并执行攻击者恶意制造的网页程序。这些恶意网页程序通常是JavaScript,但实际上也可以包括Java、 VBScript、ActiveX、 Flash 或者甚至是普通的HTML。攻击成功后,攻击者可能得到包括但不限于更高的权限(如执行一些操作)、私密网页内容、会话和cookie等各种内容。

该漏洞源于WEB应用缺少对客户端数据的正确验证。该漏洞主要包含:

1.标识签名输入的HTML编辑器中可能存在跨站点脚本

2.带有恶意svg内容的HTML消息的跨站点脚本

3.带有恶意数学内容的HTML消息跨站点脚本

Roundcube使用Washtml HTML清理程序的自定义版本在电子邮件中显示不受信任的HTML代码。其中一个修改是为svg标记包含一个异常,以正确处理XML命名空间。但是,处理协议中的漏洞会导致清理检查失败。这可以通过JavaScript负载滥用命名空间属性进行攻击。例如通过包含HTML onload事件的恶意电子邮件来利用此漏洞。如果触发,则可能导致存储的XSS攻击。

成功的攻击允许在经过身份验证的受害者会话的上下文中执行任意JavaScript代码,从而基本上模拟了登录的用户。这赋予了攻击者与合法用户相同的权力,包括但不限于:阅读和删除邮件,代表受害者发送电子邮件,访问地址列表,以及进行垃圾邮件运动。攻击者可以从个人信件中获取其他敏感信息,这些信息可能使恶意行为者能够访问外部服务,例如纯文本凭据和确认电子邮件。

解决方案

该漏洞已在Roundcube 1.4.8中修复。

查看漏洞详细信息 以及升级请访问官网:

https://github.com/roundcube/roundcubemail/releases/tag/1.4.8

身份签名输入的HTML编辑器中潜在的XSS问题

来源:TechWeb.com.cn

标签:邮件系统漏洞Roundcube

我的评论:

请  后发表评论。